Jump to content
Featured Clans:

Search the Community

Showing results for tags 'loading'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Royale Ramblings
    • Announcements
    • FAQ
    • News
    • Contests
    • General Chat
    • Off-Topic
    • Rants & Raves
  • Royale Recruitment
    • Recruiting: 1000+ Trophies
    • Recruiting: 2000+ Trophies
    • Recruiting: 3000+ Trophies
    • Recruiting: 4000+ Trophies
    • Recruiting: 4500+ Trophies
    • Recruiting: 5000+ Trophies
    • Recruiting: 5500+ Trophies
    • Recruiting: 6000+ Trophies
  • Deck Help
    • Card Discussions
    • Clash Royale Decks
    • Guides
    • Videos
  • Site Help
    • Questions
  • Rebel Riot Club's Check Us Out!
  • Rebel Riot Apex's Check Us Out!
  • Rebel Riot Jr's Check Us Out!

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Player Tag


Clan Tag


In-Game Link

Found 16 results

  1. submitted by /u/-BabyYoda [link] [comments] View the full article
  2. submitted by /u/Rehaanroxx [link] [comments] View the full article
  3. submitted by /u/RoyalDragon56 [link] [comments] View the full article
  4. submitted by /u/Kingzram [link] [comments] View the full article
  5. Don't know if it's a bug or not but I haven't been able to play party mode for 2 days now, it just keeps loading even after a few minutes. I have a stable connection since I can play every other mode including 2v2 just fine but not the heist/infinite elixir ones. I've tried to reinstall, playing on another device, deleting data/cache, downgrading, and restarting my device with no results. The only thing I can think of so far is contacting Supercell support but looking at other posts it seems they can't do anything. Does anybody know a fix to this? submitted by /u/Jin0719 [link] [comments]View the full article
  6. Since yesterday's maintainance break, my game Loading screen stops at about 50% mark and doesnt move forward. It takes about 5 minutes to enter the game, but it's of no use as i enter the game i get the wifi icon on the screen. I can't neither request cards, nor open any chest. My internet works fine in the other apps. Is it just me or someone else too? submitted by /u/hasmukh_janwa [link] [comments]View the full article
  7. My game for like the past day will get to 50% then say updating then a minute later it will say failed to load. submitted by /u/2205037 [link] [comments]View the full article
  8. Can we have a countdown after loading in a game or remove the animations? Sometimes the opponent has troops at my princess tower while Im not even able to play a card yet. If they use the notrious ebarb rage combo they have guaranteed damage and there's nothing I can do about it. Or am I missing something? submitted by /u/Chippie92 [link] [comments]View the full article
  9. submitted by /u/BIOLOGYSCIENCE [link] [comments] View the full article
  10. submitted by /u/dl_supertroll [link] [comments] View the full article
  11. submitted by /u/CanIusethetoilet [link] [comments] View the full article

New Guides

About Us

"This content is not affiliated with, endorsed, sponsored, or specifically approved by Supercell and Supercell is not responsible for it. For more information see Supercell's Fan Content Policy: www.supercell.com/fan-content-policy."

731469787_CRRLogo.png.3c26e84a2820c04b77

×
×
  • Create New...